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Premiers pas avec STM32 Nucleo dans Arduino IDE

Ceci est un guide de démarrage sur STM32 Nucleo avec Arduino IDE . Dans ce didacticiel, nous apprendrons a
utiliser les cartes STM32 Nucleo avec le cadre de programmation Arduino. Dans un premier temps, nous verrons
comment installer le framework STM32duino dans I'IDE Arduino. Deuxi€mement, nous verrons un exemple de
clignotement de LED pour utiliser les broches GPIO de la carte Nucleo comme broches de sortie numérique.

Présentation des cartes Nucleo STM32

ST Microelectronics a introduit des cartes de développement puissantes, économiques et abordables par rapport
aux cartes de découverte STM32. Parce que les cartes découverte ont des prix plus élevés que les cartes Nucleo.
Ces cartes vous permettent de développer et de prototyper votre application rapidement a moindre codt. Plus
important encore, ils sont compatibles avec un grand nombre de modules complémentaires matériels disponibles
pour Arduino Uno et Arduino Nano.

Trois sont trois principaux types de sangliers Nucleo qui sont classés en termes de taille de flash, de hautes
(X)performances, de puissance ultra-faible et de fonctions de capacité sans fil telles que Nucleo-32, Nucleo -64 et
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Il existe différents environnements de programmation disponibles pour programmer les cartes Nucleo telles que

Arduino, STM32Cube, Mbed, Zephyr RTOS, etc. Mais nous utiliserons le framework Arduino dans cette série de
tutoriels.

Pourquoi utiliser Arduino pour programmer les cartes Nucleo STM32 ?

La principale raison d'utiliser Arduino pour programmer les cartes STM32 est due a la simplicité et a la facilité
d'utilisation de I'IDE Arduino pour programmer diverses cartes. Deuxiemement, si vous connaissez déja Arduino et
que vous l'avez utilisé pour programmer des cartes Arduino, vous pouvez facilement appliquer cette expérience
pour programmer également des cartes STM32. Plus important encore, I'équipe officielle de STM32 Core a porté
toutes les cartes Nucleo et autres cartes STM32 dans I'IDE Arduino. Cela signifie que nous pouvons utiliser les
mémes APl Arduino pour utiliser les cartes STM.

Vous pouvez obtenir plus d'informations sur le noyau Arduino STM32 a partir de ce référentiel .

Installation du noyau STM32 dans I'IDE Arduino
Apreés avoir brievement présenté les cartes Nucleo STM32 et le noyau Arduino STM32, voyons comment installer la
®bib|iothéque STM32 dans I'IDE Arduino.

rer que I'IDE Arduino est installé sur votre systéeme. Téléchargez et installez
(ploitation tels que Windows, Linux et MAC,
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Ajout du package de support de carte

Aprés avoir installé I''DE Arduino, nous devons ajouter un package de support de carte du noyau Arduino STM32
dans I'IDE Arduino. Le gestionnaire de packages de support de carte vous permet d'ajouter des cartes
supplémentaires dans I''DE Arduino. Suivez ces étapes pour ajouter STM32 :

Ouvrez IDE et cliquez sur Fichiers -> Préférences :

@ ch_dec16a | Arduino 1.8.16 (Windows Store 1.8.51.0) =3 O X
File§Edit Sketch Tools Help

New Ctrl+N

Open... Ctrl+O

Open Recent

Sketchbook

Bampies )ie here, to run once:
Close Ctrl+W

Save Ctrl+S

Save As... Ctrl+Shift+S

Page Setup  Ctrl+Shift+P
Print Ctrl+P

re, to run repeatedly:

0

Preferences Ctrl+Comma

Quit Ctrl+Q

Apreés cela, la fenétre "Préférences" apparaitra. Cliquez sur la case rectangulaire a c6té de "URL supplémentaires du
gestionnaire de tableaux".

®
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Preferences X

Settings Network

Sketchbook location:

C:\Users\vadion\Documents\Arduino Browse
Editor language: System Default v (requires restart of Arduino)

Editor font size: 14

Interface scale: Automatic | 100 3 % (requires restart of Arduino)

Theme: Default theme | (requires restart of Arduino)

Show verbose output during: [_| compilation [_] upload

Compiler, warnings: None v
pablicite
[] pisplay line numbers [] Enable Code Folding
Verify code after upload [] use external editor
Check for updates on startup Save when verifying or uploading

[] use accessibility features

Additional Boards Manager URLs: |sp32_index.json, http://arduino.esp8266.com/stable/package_esp8266com_index.jso
More preferences can be edited directly in the file
C:\Users\vadion\Documents\ArduinoData\preferences.txt

(edit only when Arduino is not running)

OK Cancel

Ajoutez maintenant le lien suivant dans le champ « URL supplémentaires des administrateurs de tableaux » :

4 sur 17

https://github.com/stm32duino/BoardManagerFiles/raw/main/package_stmicroelectronics_index.json

Selon les cartes supplémentaires que vous avez utilisées avec Arduino IDE, il peut déja y avoir d'autres URL.
Vous devez les ajouter a une nouvelle ligne. Maintenant, cliquez sur "OK" pour enregistrer les parameétres.
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@ Additional Boards Manager URLs

Enter additional URLs, one for each row

https://microcontrollerslab-com.translate.goog/st...

X

https://dl.espressif.com/dl/package_esp32_index.json

RLLp://arduino,csps2€6, com/stable/package =spa266 ind s

https://github.com/stm32duino/BoardManagerFiles/raw/main/package_stmicroelectronics_index.j sonl

Click for a list of unofficial boards support URLs

Allez maintenant dans outils> tableau> Gestionnaire de tableaux

Publicite

File Edit Sketch Tools Help

Auto Format Ctrl+T

& WiFiScan | Arduino 1.8.7 - m]

OK

WiFi101 Firmware Updater

Board: "ESP32 Dev Module”

Serial.pr| Upload Speed: "921600"
} CPU Frequency: "240MHz (WiFi/BT)"
void loop() Flash Frequency: "80MHz"
{ Flash Mode: "QIO"

Efcialpr Flash Size: "4MB (32Mb)"

i Partition Scheme: "Default”

// WiFi.s

Core Debug Level: "None"
PSRAM: "Disabled"

Port: "COM5"

< Get Board Info

Programmer: "AVRISP mkll*

Burn Bootloader

Miodule, Disabled, Default, 240MHz (WiFi/BT), Q10, BOMHz, 4MB (32Mb), 921600, Nong

Archive Sketch
WiFiScan Fix Encoding & Reload
{ x Manage Libraries... Ctrl+Shift+|

Serial.be -
Serial Monity Ctrl+Shift+M
erial Monitor rl+Shift+ e e

// Set Wil Serial Plotter Ctrl+Shift+L SP

. A |IDE

LilyPad Arduino
Arduino Pro or Pre Mini
Arduino NG or older
Arduino Robot Control
Arduino Robot Motor
Arduino Gemma
Adafruit Circuit Playground
Arduino Ydn Mini
Arduino Industrial 101
Linine One

ESP32 Arduino

ESP32 Dev Module
ESP32 Wrover Module
ESP32 Pico Kit

Turta loT Node

TTGO LoRa32-OLED V1
XinaBox CW02

Cancel

Apreés cela, une fenétre de gestionnaire de carte s'ouvrira ou vous pourrez voir une liste des cartes installées dans
votre IDE Arduino.

S5sur17
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® Boards Manager X

Type |All v |
Arduino AVR Boards ~

Built-In by Arduino version 1.8.3 INSTALLED

Boards included in this package:

Arduino Yun, Arduino Uno, Arduino Uno Mini, Arduino Uno WiFi, Arduino Diecimila, Arduino Nano, Arduino Mega, Arduino MegaADK, Arduino
Leonardo, Arduino Leonardo Ethernet, Arduino Micro, Arduino Esplora, Arduino Mini, Arduino Ethernet, Arduino Fio, Arduino BT, Arduino
LilyPadUSB, Arduino Lilypad, Arduino Pro, Arduino ATMegaNG, Arduino Robot Control, Arduino Robot Motor, Arduino Gemma, Adafruit Circuit
Playground, Arduino Y(n Mini, Arduino Industrial 101, Linino One.

Online Help

More Info

Select version | Install Update
Arduino Mbed 0S Edge Boards

by Arduino Publicité
Boards includchin %tlsepackage:

Arduino Edge Control.

Online Help
More Info

Arduino Mbed 0S Nano Boards

by Arduino

Boards included in this package:

Arduino Nano 33 BLE, Arduino Nano 33 BLE Sense, Arduino Nano RP2040 Connect.

Online Help v

Close

Tapez les « cartes basées sur MCU STM32 » dans la barre de recherche et sélectionnez « cartes basées sur MCU
STM32 » et cliquez sur le bouton d'installation :

@ Boards ManaN X
Type |All v ISTM32 MCU based boards| I

STM32 MCU based boards A

by STMicroelectronics

Boards included in this package:

Nucleo-144, Nucleo-64, Nucleo-32, Discovery, Eval, STM32MP1 series coprocessor, Generic STM32F0 series, Generic STM32F1 series, Generic
STM32F2 series, Generic STM32F3 series, Generic STM32F4 series, Generic STM32F7 series, Generic STM32G0 series, Generic STM32G4 series,
Generic STM32H7 Series, Generic STM32L0 series, Generic STM32L1 series, Generic STM32L4 series, Generic STM32L5 series, Generic STM32U5
series, Generic STM32WB series, Generic STM32WL series, 3D printer boards, Blues Wireless boards, Elecgator boards, Electronic speed
controllers, Garatronic-McHobby, Generic Flight Controllers, LoRa boards, Midatronics boards.

Online Hel
More Info \

2.1.0 v Install

6sur 17

Close

et APl de base STM32 Arduino requises. Une fois l'installation terminée, un
3 du nom du noyau STM32.
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@ Boards Manager g
Type All v | |\STM32 MCU based boards
STM32 MCU based boards A
by STMicroelectronics version 2.1.0 INSTALLED
Boards included in this package:
Nucleo-144, Nucleo-64, Nucleo-32, Discovery, Eval, STM32MP1 series coprocessor, Generic STM32F0 series, Generic STM32F1 series, Generic
STM32F2 series, Generic STM32F3 series, Generic STM32F4 series, Generic STM32F7 series, Generic STM32G0 series, Generic STM32G4 series,
Generic STM32H7 Series, Generic STM32L0 series, Generic STM32L1 series, Generic STM32L4 series, Generic STM32L5 series, Generic STM32WB
series, Electronic speed controllers, LoRa boards, 3D printer boards, Generic Flight Controllers, Garatronic-McHobby, Midatronics boards.
Online Help
More Info
-
Select version v Install Remove
Publicité
C'est ¢a. Vous pouvez installer le noyau Arduino STM32 dans I'IDE Arduino. Vous pouvez maintenant fermer la
fenétre du gestionnaire de carte.
To check if the library is installed properly or not, you can go to tools > boards > stm32 boards groups. You can
select the Nucleo boards such as Nucleo-64, Nucleo-144, etc.
®
dec16a | Arduig@®.8.16 (Windows Store 1.8.51.0) = O X
etc elp
Auto Format Ctrl+T
Archive Sketch
ar ],31 Fix Encoding & Reload
5y (; Manage Libraries... Ctrl+Shift+| N
i y | Serial Monitor Ctrl+Shift+M
" 77 Serial Plotter Ctrl+Shift+L
Nucleo-144
- Mudee' Boards Manager..
. yq  CPUFrequency: Nudeo 32 Arduino AVR Boards >
| Flash Frequency: Discavery ESP32 Arduino >
ESP8266 Boards (3.0.1) >
:; CopLoE=Cl “ STM32 boards groups (Board to be selected from Tools submenu 'Board part number’) |
series .
F1 series
F2 series
F3 series
F4 series
00:39 / 03:20 F7 series X
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write your first program and upload it to the STM32 Nucleo board.

In this tutorial, we will use the Nucleo-F103RB board. But you can use any other Nucleo board also and follow the
same instructions to program your boards.

The Nucleo-F103RB board which we are using in this tutorial belongs to Nucleo-64 types. Therefore select,
Nucleo-64 from STM32 board groups. You can select other Nucleo types according to the board which you are using
such as Nucleo-32 and Nucleo-144.

) sketch_dec16a | Arduino 1.8.16 (Windows Store 1.8.51.0) - m} X
File Edit Sketch Tools Help

Auto Format Ctrl+T
PabHeité
Fix Encoding & Reload

Manage Libraries... Ctrl+Shift+l 7
Serial Monitor Ctrl+Shift+M
Serial Plotter Ctrl+Shift+L
WiFi101 / WiFiNINA Firmware Updater /
Board: "Nucleo-64" )I _ Boards Manager... .
Board part number: “Nucieo FO30R8" | Arduino AVR Boards Nucleg-144
U(S)ART supp?m "E.nabled (generic ‘Serial)" 3 ESP32 Arduino k|
} USB support (if available): “None" 2 ESP8266 Boards (3.0.1) 2 Nucleo-32
USB speed (if available): "Low/Full Speed" i STM32 boards groups (Board to be selected from Tools submenu ‘Board part number’) * Discovery
| Optimize: “Smallest (-Os defauit)" / Eval
Debug symbols: "None" > STM32MP1 series coprocessor
C Runtime Library: “Newlib Nano (default)" > - Generic STM32F0 series
Upload method: “Mass Storage” > Generic STM32F1 series
Port Generic STM32F2 series
Get Board Info Generic STM32F3 series
Programmer > Generic STM32F4 series
Generic STM32F7 series

Burn Bootloader

As mentioned earlier, there are many variants of Nucleo boards that come with different STM32 chips. The one
which we are using has a part number of Nucleo-F103RB. Hence, select your board part number from Tools > Board
Part Number:
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| @ sketch_dec16a | Arduino 1.8.16 (Windows Store 1.8.51.0)

sketch_dec16
void setup(
put yo

File Edit Sketc Tools

//

= O X
elp
Auto Format Ctri+T
Archive Sketch
Fix Encoding & Reload
Manage Libraries... Ctrl+Shift+|
Serial Monitor Ctrl+Shift+M
Serial Plotter Ctri+Shift+L

WiFi101 / WIFiNINA Firmware Updater

vid loop (WIEO’M-
put ol Board part aumber: “Nicieo F103RB

Nucleo FO30R8

Publicité
}

U('S-)ART support: "Enabled (generic FS-eT'EF)"
USB support (if available): "None"

USB speed (if available): "Low/Full Speed"”
Optimize: "Smallest (-Os default)”

Debug symbols: “None"

C Runtime Library: “Newlib Nano (default)”
Upload method: "Mass Storage”

Port

Get Board Info

Programmer
Burn Bootioader

% Nucleo FO70RB
j Nucleo FO72RB
% Nucleo F091RC

S

>" Nucleo F302R8
¥ Nucleo F303RE
Nucleo F401RE
Nucleo F411RE
Nucleo F446RE
Nucleo GO71RB
" Nucleo GOB1RE

Nucleo G431RB

STM32 Nucleo LED Blinking Example

Now let's see a sample LED blinking example available in examples of Arduino IDE. To open the LED blinking
example go to File > Examples > Basics > Blink and click on it. It will open a simple LED blinking example which will
blink onboard LED of Nucleo-F103RB at the rate of 1 second.

@ s h_dec16a | Arduino 1.8.16 (Windows Store 1.8.51.0) — O X
FileJEdit Sketch Tools Help
New Ctrl+N
Open... Ctrl+O
Open Recent
I Examples e
Close Ctrle W Bvuﬂt-u? Examples :
Shve Ctrl+S I 01.Be_15|.<s Analog.R.eadSenaI
Save As..  Ctrl+ShiftsS 02Drgital IagurdicMininun
03.Analog >i| Blink |
Page Setup  Ctrl+Shift+P 04.Communication >‘ DigitalReadSerial
Print Ctri+P 05.Control >‘ Fade
Drcferonces . GtiliComma 06.Sensors > ReadAnalogVoltage
07.Display >
Quit Ctri+Q 08.Strings >
09.USB >
10.StarterKit_BasicKit >
® 11.ArduinolSP >
second, then off for one second, repeatedly.
00:39 / 03:20
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If you want to know what pin the on-board LED is connected to on your Arduino
model, check the Technical Specs of your board at:
https://www.arduino.cc/en/Main/Products

modified 8 May 2014
by Scott Fitzgerald
modified 2 Sep 2016
by Arturo Guadalupi
modified 8 Sep 2016
by Colby Newman

This %&QWB%% code is in the public domain.

https://www.arduino.cc/en/Tutorial/BuiltInExamples/Blink
*/

// the setup function runs once when you press reset or power the board
void setup() {

// initialize digital pin LED _BUILTIN as an output.

pinMode (LED_BUILTIN, OUTPUT);

// the loop function runs over and over again forever
void loop() {
digitalWrite(LED_BUILTIN, HIGH); // turn the LED on (HIGH 1is the voltage level)

delay (1000) ; // wait for a second
digitalWrite(LED_BUILTIN, LOW); // turn the LED off by making the voltage LOW
delay (1000) ; // wait for a second

The above code blinks an onboard LED of Nucleo-F103RB after every one second. This is mentioned as LD2 on the
Nucleo board and it is connected with the PA5 pin of F103RB.

Now select the COM port to which your Nucleo board is connected. Go to Tools > Ports:

00:39 / 03:20
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@ Blink | Arduino 1.8.18
‘File Edit Sketchj Tools fHelp -

Blink

ndows Store 1.8.51.0)

Auto Format
Archive Sketch

Fix Encoding & Reload
Manage Libraries...
Serial Monitor

Serial Plotter

WIFi101 / WiFiNINA Firmware Updater

Board: "Nucleo-64"

Board part number: "Nucleo F103RB"
U(S)ART support: "Enabled (generic ‘Serial’)"
USB support (if available): "None"

USB speed (if available): "Low/Full Speed"
Optimize: "Smallest (-Os default)”

Debug symbols: "None"

C Runtime Library: "Newlib Nano (default)”
Upload method: "Mass Storage”

Ctrl+Shift+|
Ctrl+Shift+M
Ctrl+Shift+L

Port

Get Board Info

Programmer
Burn Bootloader

Serial ports
COM3

After that, compile the code and hit on upload button to upload code to the Nucleo board.
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// the setup function runs once when you press reset or power th
void setup() { |
// initialize digital pin LED BUILTIN as an output.
pinMode (LED_BUILTIN, OUTPUT);

// the loop function runs over and over again forever

loop() {
alWrite (LED BUILTIN, HIGH):; // turn the LED on (HIGH is
(1000) ; // wait for a second
digitalWwrite (LED BUILTIN, LOW); // turn the LED off by makii
delay (1000); // wait for a second

of dynamic memory, leaving 1

drage, Enahle eric 'Serial wiFull Speed, Smallest (-Os default), No wlib Nano (default) on COM8

After uploading the code, you will notice that the onboard LED of the Nucleo board will start blinking as follows:

00:39 / 03:20

12 sur 17 09/08/2023 16:01


https://microcontrollerslab-com.translate.goog/stm32-nucleo-arduino-ide-tutorial/?_x_tr_sl=auto&_x_tr_tl=fr&_x_tr_hl=fr#
https://microcontrollerslab-com.translate.goog/stm32-nucleo-arduino-ide-tutorial/?_x_tr_sl=auto&_x_tr_tl=fr&_x_tr_hl=fr#

Premiers pas avec STM32 Nucleo dans Arduino ID... https://microcontrollerslab-com.translate.goog/st...

In summary, in this tutorial, we have learned to use STM32 Nucleo boards with Arduino. Firstly, we have seen an
Introduction to Nucleo boards. Secondly, we have learned to install STM32 Arduino Core in Arduino IDE. In the end,

we see how to program and upload code to the Nucleo board using Arduino IDE.

You may also like to read:

¢ LED Blinking Tutorial STM32F4 Discovery Board - GPIO Pins with HAL Library
o Getting started with Keil uVision: Write your first Program for Tiva LaunchPad
e STM32 Blue Pill GPIO Pins with STM32Cube IDE: LED Blinking Tutorial

# STM32 Nucleo

Subscribe to Blog via Email
Entrez votre adresse e-mail pour vous abonner a ce blog et recevoir les notifications de nouveaux articles par

e-mail.

®
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Serveur Web de commutateur momentané ESP32/ESP8266 : contrdler les sorties GPIO
Reconnectez ESP32 au WiFi aprés une perte de connexion (résolu)

ESP32 avec accélérometre, gyroscope et capteur de température MPU6050 (IDE Arduino)

ESP32 Enregistrer les données sur Flash en permanence a l'aide de la bibliothéque de préférences

ESP32 conserve le dernier état GPIO aprés une réinitialisation
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